Jump to content

logic pro x "system overload". blir galen snart.


Recommended Posts

Hej!

Vet att ämnet är uttjatat men har googlat och provat alla lösningar utan resultat. Så därför provar jag här.

Jag har en macbook pro(2010) som jag har satt in 8gb ramminne i och 240 gb ssd disk.

Använder Logic pro x och spelar in via ett motu 8 pre Ljudkort.

Jag använder pluggar som Ezdrummer, Ezmix och Amplitube 3 och Logics egna inbyggda.(alla givetvis köpta)

När jag spelar in så dyker det allt som oftast upp ett "system overload" meddelande vilket börjar bli så irriterande att jag börjar tröttna rejält. snacka om kreativitetsdödande.

Nu senast höll jag på med ett spår. Jag bestämmer mig för att ha ett intro. varpå jag spelar in 3 olika gitarrer (2 komgitarrer och en melodi) och efter 2 takter så kommer trummor/gitarrer/bas in och kör igång. Så fort de första trumslagen börjar så pausas allt och system overload meddelandet dyker upp. Jag själv kan jag tycka att det är galet konstigt. hade ju förstått om det var 95 instrument som kickar igång samtidigt men så är inte fallet.

Jag har provat allt (stänga av alla andra aktiva program(time, machine, safari, Wifi mm). Jag har testat att köra "Freeze träcks" och även ändrat buffeminnet men inget hjälper.

Jag misstänker ju att jag har klantat till det med nån inställning. Hade även samma problem när jag körde logic express.

Någon som har nåt förslag? Kan det vara så att datorn är för gammal?

Tack på förhand.

Med vänlig hälsning/Jani

Link to post
Share on other sites
Annons

Prova det ibland eller ofta kan det hjälpa, beror dock på vad felet naturligtvis är. Har du provat något annat DAW om det blir samma sak där? tex Reaper, Ableton, Cubase.

Edited by hellfog
Link to post
Share on other sites

Förra året slutade ett av våra ramminnen att fungera så helt plötsligt hade vi bara 2 gig. När vi satte in nya minnen gick datorn bra igen. Tryck på äpplet och "om den här datorn" för att snabbt kolla så du får ut 8 gig i ram.

Link to post
Share on other sites

Prova det ibland eller ofta kan det hjälpa, beror dock på vad felet naturligtvis är. Har du provat något annat DAW om det blir samma sak där? tex Reaper, Ableton, Cubase.

Har inte testat något annat DAW. ska göra det om jag får möjlighet.

Förra året slutade ett av våra ramminnen att fungera så helt plötsligt hade vi bara 2 gig. När vi satte in nya minnen gick datorn bra igen. Tryck på äpplet och "om den här datorn" för att snabbt kolla så du får ut 8 gig i ram.

Tack för tipset. kollade det men mina ramminnen funkade fint:)

Link to post
Share on other sites

Uppdatering:

Blåste rent hela macbooken och installerade allt från början igen. Samma problem kvarstår. Det är konstigt för det är vissa partier på vissa låtar som det blir "system overload"(givetvis låtarna man är mest nöjd med) och jag fattar ingenting.

ska luska vidare på problemet och hoppas jag hittar felet. stort tack för alla tips.

Med vänlig hälsning, Jani

Link to post
Share on other sites

Syns det nåt i Logics "System Performance Window" när det händer ?

Hur ser det ut i OSX Activity Monitor ?

Kör du allt från systemdisken ?

Hur mycket ledigt utrymme på disken/diskarna ?

Link to post
Share on other sites

Syns det nåt i Logics "System Performance Window" när det händer ?

Hur ser det ut i OSX Activity Monitor ?

Kör du allt från systemdisken ?

Hur mycket ledigt utrymme på disken/diskarna ?

Ja det syns i logics "system performacen window". Hdd mätaren rör sig inte men processor mätaren går i taket.

Hur hittar jag OS X activity monitor?

Jag har 280 gb ledigt ungefär på systemdisken. (320 gb disk). Jag kör logic projekten från en usb 2.0 disk(sen igår).

Link to post
Share on other sites

Vad spelar du in på, hur snabb är hårddisken? Du kör väl bara program på SSD:n?

mvh/Peter

Jag spelar in på en usb disk och har bara program på ssdn. Har inte gjort så innan men testar och ser utan resultat.

Jag kan ha många instrument på men så fort något ändras i låten(exempelvis, trummor, bas gitarr försvinner och en ack-gura börjar spela så "overloadar" den direkt.

Link to post
Share on other sites

Hur hittar jag OS X activity monitor?

Sorry, menar "Aktivitetsskontroll" under "Verktygsprogram" 🙂

Vilken processor har din maskin ?

Prövat de olika inställningarna i Logic Pro X > Preferences > Audio, Processing Threads ?

Vad kör du för I/O Buffer Size ?

Edited by JakobP
Link to post
Share on other sites

Sorry, menar "Aktivitetsskontroll" under "Verktygsprogram" 🙂

Vilken processor har din maskin ?

Prövat de olika inställningarna i Logic Pro X > Preferences > Audio, Processing Threads ?

Vad kör du för I/O Buffer Size ?

Kollade aktivitetskontroll precis och Logic använde runt 60%.

Har inte provat "processing threads"

Buffer sizen har jag minskat/ökat men tycker inte det blir nån skillnad.

Datorn är en macbook pro mitten 2010.

Processor 2,4 ghz intel core duo 2.

8 gb 1067 mhz ddr3 och samsung ssd disk(240).

Det skumma är att jag kan ha 7-8 kanaler igång med trummor(logics egna), gitarrer och bas och det flyter på skitbra men så fort det blir en stor ändring i låtarrangemanget som exempelvis att allt övergår från fullt ös till jättelugnt(med bara en gitarr) så "overloadar" den direkt. Spelade in ett klipp på telefonen men vet inte hur jag kan länka den hit.

Med vänlig hälsning,/Jani

Link to post
Share on other sites

Jag spelar in på en usb disk och har bara program på ssdn. Har inte gjort så innan men testar och ser utan resultat.

Jag kan ha många instrument på men så fort något ändras i låten(exempelvis, trummor, bas gitarr försvinner och en ack-gura börjar spela så "overloadar" den direkt.

Och du har stängt av Wi-Fi och sådant?

Link to post
Share on other sites

Hej Jani77.

Det är inget fel på din interna hårddisk utan det är din processor som blir överbelastad.

Mitt råd till dig för att göra följande

* Spela in på din interna SSD-hårddisk, att spela in på en USB2-hårddisk kräver mer processorprestanda än att spela in på din interna hårddisk.

* Flytta över alla projekt som du inte använder till din USB2-hårddisk, detta för att spara plats på din interna hårddisk. Givetvis tar du backup på din USB2-hårddisk där all musik finns sparad via TimeMachine.

* I Logic. Följ guiden som hellfog redan påvisat (http://support.apple.../en-us/HT203930). Gör följande inställningar i Logic och "preferences"

I/O Buffert Size: 256 samples. Ju färre antal samples, ju större processorbelastning

Processing Threads: Automatic

Process Buffer Range: Large

Likaså bör du inte ha igång något annat program än just Logic när du håller på med musik för att din begränsade processorkapacitet skall användas endast för Logic.

För att få reda på hur snabb din dator är jämfört med andra Mac-datorer kan jag rekommendera dig att titta på geekbench (http://browser.prima.../mac-benchmarks). Använd 64-bitar multicore i din jämförelse och om jag fått allt rätt får din dator, MacBook Pro (15-inch Early 2010) Intel Core i5-520M 2400 MHz (2 cores), 4106 poäng vilket är mindre bra.

EDIT: Lagt till jämförelse till Geekbench

EDIT2: Process Buffer Range, från "High" till "Large"

Edited by Implasticyde
Link to post
Share on other sites

Logic är riktigt uselt på processhantering. Det kan hända ibland att den lägger mer än vad den klarar av på en kärna, och man kan få starta och stanna låten några gånger innan den lär sig att distribuera rätt.

Alla andra DAWs jag provat (och jag har testat rätt hårt) lyckas krama ut bra mycket mer av en processor än vad Logic kan. Trots att Logic egentligen är effektivare per process.

Det är därför en i7 presterar så mycket bättre med Logic. Den hjälper till att maskera bristerna i Logic.

Jag fick ganska ofta system overload på min macbook i kombination med EZ Drummer. Verkar som den sitter och sover ibland och hinner inte leverera samplingarna i tid.

Jag har inte märkt av problemet med EZD2 (peppar peppar).

Har du kört några benchmarks på din SSD? Det skulle ju mycket väl kunna vara något konflikfel som gör att den presterar sämre än den ska.

Link to post
Share on other sites

Hej Jani77.

Det är inget fel på din interna hårddisk utan det är din processor som blir överbelastad.

Mitt råd till dig för att göra följande

* Spela in på din interna SSD-hårddisk, att spela in på en USB2-hårddisk kräver mer processorprestanda än att spela in på din interna hårddisk.

* Flytta över alla projekt som du inte använder till din USB2-hårddisk, detta för att spara plats på din interna hårddisk. Givetvis tar du backup på din USB2-hårddisk där all musik finns sparad via TimeMachine.

* I Logic. Följ guiden som hellfog redan påvisat (http://support.apple.../en-us/HT203930). Gör följande inställningar i Logic och "preferences"

I/O Buffert Size: 256 samples. Ju färre antal samples, ju större processorbelastning

Processing Threads: Automatic

Process Buffer Range: Large

Likaså bör du inte ha igång något annat program än just Logic när du håller på med musik för att din begränsade processorkapacitet skall användas endast för Logic.

För att få reda på hur snabb din dator är jämfört med andra Mac-datorer kan jag rekommendera dig att titta på geekbench (http://browser.prima.../mac-benchmarks). Använd 64-bitar multicore i din jämförelse och om jag fått allt rätt får din dator, MacBook Pro (15-inch Early 2010) Intel Core i5-520M 2400 MHz (2 cores), 4106 poäng vilket är mindre bra.

EDIT: Lagt till jämförelse till Geekbench

EDIT2: Process Buffer Range, från "High" till "Large"

Stort tack för infon. har gjort alla inställningar som du skrev om. Det skumma är som sagt att det bara är vissa partier. testade att importera projektet till min macbook air (2012) och där upplevde jag att det flöt bättre. kanske dags att börja spara till en ny macbook snart då🙁

Link to post
Share on other sites

Logic är riktigt uselt på processhantering. Det kan hända ibland att den lägger mer än vad den klarar av på en kärna, och man kan få starta och stanna låten några gånger innan den lär sig att distribuera rätt.

Alla andra DAWs jag provat (och jag har testat rätt hårt) lyckas krama ut bra mycket mer av en processor än vad Logic kan. Trots att Logic egentligen är effektivare per process.

Det är därför en i7 presterar så mycket bättre med Logic. Den hjälper till att maskera bristerna i Logic.

Jag fick ganska ofta system overload på min macbook i kombination med EZ Drummer. Verkar som den sitter och sover ibland och hinner inte leverera samplingarna i tid.

Jag har inte märkt av problemet med EZD2 (peppar peppar).

Har du kört några benchmarks på din SSD? Det skulle ju mycket väl kunna vara något konflikfel som gör att den presterar sämre än den ska.

Tack för infon. Mycket jag inte vet märker jag nu:) har inte kört benchmarks på min sed men ska göra det så fort jag hinner.

Tror du problemet försvinner om jag köper en dator med antingen i5 eller i7 processor?

Med vänlig hälsning,/Jani

Link to post
Share on other sites

Stort tack för infon. har gjort alla inställningar som du skrev om. Det skumma är som sagt att det bara är vissa partier. testade att importera projektet till min macbook air (2012) och där upplevde jag att det flöt bättre. kanske dags att börja spara till en ny macbook snart då 🙁

Nu antar jag att du har senaste drivrutinerna till ditt ljudkort och att du uppdaterat både Logic och ditt operativsystem. Om svaret är nej på något av mina påståenden rekommenderar jag dig att uppdatera.

För att ta reda på exakt vad det är som får Logic att krokna rekommenderar jag dig att ta fram Logics egna "System Performance Window" enligt Hellfogs tips ovan. Mest troligt är det din processor som inte hänger med men du får beviset i Logics "System Performance Window". Se vilken av mätarna som slår i taket, där är datorns begränsning.

Misstänker att de partier där din processor inte hänger med är där du har lagt på "mycket" mjukvarueffekter eller "instrument". Att spela upp audiofiler i Logic är inget som belastar Logic nämnvärt. Något som drar mycket processorkraft är multibandskompressor och reverb. För reverb är det bästa att använda sig av "bus" och lägga reverbet där. På så sätt kan du använda dig av samma reverb till vad du vill och därmed minska processorbelastningen jämfört med att lägga ett separat reverb per kanal.

Använd Geekbench som jag hänvisade till i mitt första svar till dig för att få en fingervisning om prestandan för de datorer du testar.

Gällande köp av ny dator så passa dig för nya Mac mini, MacBook Air och Macbook Pro 13" då de datorerna endast har dual core processorer. Satsa på en dator som har quad core i7 CPU så har du massor av processorkraft att nyttja. På blocket finns en dator som jag hade rekommenderat dig att titta närmare på: http://www.blocket.s...5.htm?ca=20&w=3

EDIT: Förtydligande

Edited by Implasticyde
Link to post
Share on other sites

Bra svar från både rainydays och Implasticyde. Jag skulle gissa på en kombination av kanalpresets med tunga pluggar (Logic har en förmåga att i använda mallar där de slängt ett lass av inserteffekter på varje spår) och att krävande instrumentbibliotek körs från USB-hårddisk och inte hinner leverera.

Jag har inte använt EZdrummer 2, men folk i min omgivning säger att det laddar snabbare och inte känns lika tungt för datorn. Det är trots allt hundratals ljudfiler per trumma som ska laddas. En uppgradering till version 2 kan säkert vara värt det innan du springer och köper ny dator.

Lägg ljudbankerna på SSD:n i mån av plats. Audioinspelningarna kan ligga på USB-disken iom att spåren är så få.

Link to post
Share on other sites

Med risk för att verka tjatig men stort tack alla för hjälpen. Jag gick igenom mitt projekt och tog bort 2 gitarrspår och nu flyter allt på relativt bra. har fått system overload 1 gång av 10 nu ungefär och det kan man leva med. blir till att spara till en ny dator med en i7 processor så småningom:) Ha en fortsatt go helg:)

Med vänlig hälsning,/Jani

Link to post
Share on other sites

Gott att det blev bättre Jani77. Tycker att det är utmärkt av dig att återkoppla hur det går, det finns kanske fler som har samma problem i Logic som du upplever och då får även de svar på sina frågor 🙂

Link to post
Share on other sites

Med risk för att verka tjatig men stort tack alla för hjälpen. Jag gick igenom mitt projekt och tog bort 2 gitarrspår och nu flyter allt på relativt bra. har fått system overload 1 gång av 10 nu ungefär och det kan man leva med. blir till att spara till en ny dator med en i7 processor så småningom:) Ha en fortsatt go helg:)

Med vänlig hälsning,/Jani

Bästa sättet imo att spara på processorkraft är att bounca dina spår till audio.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.